CVE-2011-4944

Python 2.6 through 3.2 creates ~/.pypirc with world-readable permissions before changing them after data has been written, which introduces a race condition that allows local users to obtain a username and password by reading this file. (CVSS:1.9) (Last Update:2013-10-30)

Read more

CVE-2012-3502

The proxy functionality in (1) mod_proxy_ajp.c in the mod_proxy_ajp module and (2) mod_proxy_http.c in the mod_proxy_http module in the Apache HTTP Server 2.4.x before 2.4.3 does not properly determine the situations that require closing a back-end connection, which allows remote attackers to obtain sensitive information in opportunistic circumstances by reading a response that was intended for a different client. (CVSS:4.3) (Last Update:2013-04-18)

Read More

CVE-2012-2687

Multiple cross-site scripting (XSS) vulnerabilities in the make_variant_list function in mod_negotiation.c in the mod_negotiation module in the Apache HTTP Server 2.4.x before 2.4.3, when the MultiViews option is enabled, allow remote attackers to inject arbitrary web script or HTML via a crafted filename that is not properly handled during construction of a variant list. (CVSS:2.6) (Last Update:2013-12-05)

Read More

[ANNOUNCEMENT] Apache HTTP Server 2.4.3 Released

               Apache HTTP Server 2.4.3 Released

  The Apache Software Foundation and the Apache HTTP Server Project
  are pleased to announce the release of version 2.4.3 of the Apache
  HTTP Server ("Apache").  This version of Apache is our 3rd GA
  release of the new generation 2.4.x branch of Apache HTTPD and
  represents fifteen years of innovation by the project, and is
  recommended over all previous releases. This version of Apache is
  principally a security and bug fix release, including the following
  2 security fixes:

   *) SECURITY: CVE-2012-3502  (cve.mitre.org)
      mod_proxy_ajp, mod_proxy_http: Fix an issue in back end
      connection closing which could lead to privacy issues due
      to a response mixup. PR 53727.

   *) SECURITY: CVE-2012-2687 (cve.mitre.org)
      mod_negotiation: Escape filenames in variant list to prevent an
      possible XSS for a site where untrusted users can upload files to
      a location with MultiViews enabled.

  Apache HTTP Server 2.4.3 is available for download from:

    http://httpd.apache.org/download.cgi

  Apache 2.4 offers numerous enhancements, improvements, and performance
  boosts over the 2.2 codebase.  For an overview of new features
  introduced since 2.4 please see:

    http://httpd.apache.org/docs/trunk/new_features_2_4.html

  Please see the CHANGES_2.4 file, linked from the download page, for a
  full list of changes. A condensed list, CHANGES_2.4.3 includes only
  those changes introduced since the prior 2.4 release.  A summary of all 
  of the security vulnerabilities addressed in this and earlier releases 
  is available:

    http://httpd.apache.org/security/vulnerabilities_24.html

  This release requires the Apache Portable Runtime (APR) version 1.4.x
  and APR-Util version 1.4.x. The APR libraries must be upgraded for all
  features of httpd to operate correctly.

  This release builds on and extends the Apache 2.2 API.  Modules written
  for Apache 2.2 will need to be recompiled in order to run with Apache
  2.4, and require minimal or no source code changes.

    http://svn.apache.org/repos/asf/httpd/httpd/trunk/VERSIONING

  When upgrading or installing this version of Apache, please bear in mind
  that if you intend to use Apache with one of the threaded MPMs (other
  than the Prefork MPM), you must ensure that any modules you will be
  using (and the libraries they depend on) are thread-safe.

  NOTE to Windows users: The issues with AcceptFilter None replacing
       Win32DisableAcceptEx appears to have resolved starting with version
       2.4.3 make Apache httpd 2.4.x suitable for Windows servers.



Read More