Apache HTTP Server 2.2.24 Released

   The Apache Software Foundation and the Apache HTTP Server Project are
   pleased to announce the release of version 2.2.24 of the Apache HTTP
   Server ("Apache").  This version of Apache is principally a security
   and bug fix maintenance release, including the following significant
   security fixes:

   * SECURITY: CVE-2012-3499 (cve.mitre.org)
     Various XSS flaws due to unescaped hostnames and URIs HTML output in
     mod_info, mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp.

   * SECURITY: CVE-2012-4558 (cve.mitre.org)
     XSS in mod_proxy_balancer manager interface.

   We consider the Apache HTTP Server 2.4.4 release to be the best version
   of Apache available, and encourage users of 2.2 and all prior versions
   to upgrade.  This 2.2 maintenance release is offered for those unable
   to do so at this time.  For further details, see

     http://www.apache.org/dist/httpd/Announcement2.4.txt

   Apache HTTP Server 2.4.4 and 2.2.24 are available for download from:

     http://httpd.apache.org/download.cgi

   Please see the CHANGES_2.2 file, linked from the download page, for a
   full list of changes.  A condensed list, CHANGES_2.2.24 includes only
   those changes introduced since the prior 2.2 release.  A summary of all 
   of the security vulnerabilities addressed in this and earlier releases 
   is available:

     http://httpd.apache.org/security/vulnerabilities_22.html

   This release includes the Apache Portable Runtime (APR) version 1.4.6
   and APR Utility Library (APR-util) version 1.4.1, bundled with the tar
   and zip distributions.  The APR libraries libapr and libaprutil (and
   on Win32, libapriconv version 1.2.1) must all be updated to ensure
   binary compatibility and address many known security and platform bugs.
   APR-util version 1.4 represents a minor version upgrade from earlier
   httpd source distributions, which previously included version 1.3.

   This release builds on and extends the Apache 2.0 API and is superceeded
   by the Apache 2.4 API.  Modules written for Apache 2.0 or 2.4 will need
   to be recompiled in order to run with Apache 2.2, and most will require
   minimal or no source code changes.

   When upgrading or installing this version of Apache, please bear in mind
   that if you intend to use Apache with one of the threaded MPMs (other
   than the Prefork MPM), you must ensure that any modules you will be
   using (and the libraries they depend on) are thread-safe.



Read More

CVE-2012-4558

Multiple cross-site scripting (XSS) vulnerabilities in the balancer_handler function in the manager interface in mod_proxy_balancer.c in the mod_proxy_balancer module in the Apache HTTP Server 2.2.x before 2.2.24-dev and 2.4.x before 2.4.4 allow remote attackers to inject arbitrary web script or HTML via a crafted string. (CVSS:4.3) (Last Update:2014-01-17)

Read More

CVE-2012-3499

Multiple cross-site scripting (XSS) vulnerabilities in the Apache HTTP Server 2.2.x before 2.2.24-dev and 2.4.x before 2.4.4 allow remote attackers to inject arbitrary web script or HTML via vectors involving hostnames and URIs in the (1) mod_imagemap, (2) mod_info, (3) mod_ldap, (4) mod_proxy_ftp, and (5) mod_status modules. (CVSS:4.3) (Last Update:2014-01-17)

Read More

[ANNOUNCE] Apache HTTP Server 2.4.4 Released


               Apache HTTP Server 2.4.4 Released

  The Apache Software Foundation and the Apache HTTP Server Project
  are pleased to announce the release of version 2.4.4 of the Apache
  HTTP Server ("Apache").  This version of Apache is our latest GA
  release of the new generation 2.4.x branch of Apache HTTPD and
  represents fifteen years of innovation by the project, and is
  recommended over all previous releases. This version of Apache is
  principally a security and bug fix release, including the following
  2 security fixes:

   *) SECURITY: CVE-2012-3499 (cve.mitre.org)
      Various XSS flaws due to unescaped hostnames and URIs HTML output in
      mod_info, mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp.

   *) SECURITY: CVE-2012-4558 (cve.mitre.org)
      XSS in mod_proxy_balancer manager interface.

  Apache HTTP Server 2.4.4 is available for download from:

    http://httpd.apache.org/download.cgi

  Apache 2.4 offers numerous enhancements, improvements, and performance
  boosts over the 2.2 codebase.  For an overview of new features
  introduced since 2.4 please see:

    http://httpd.apache.org/docs/trunk/new_features_2_4.html

  Please see the CHANGES_2.4 file, linked from the download page, for a
  full list of changes. A condensed list, CHANGES_2.4.4 includes only
  those changes introduced since the prior 2.4 release.  A summary of all 
  of the security vulnerabilities addressed in this and earlier releases 
  is available:

    http://httpd.apache.org/security/vulnerabilities_24.html

  This release requires the Apache Portable Runtime (APR) version 1.4.x
  and APR-Util version 1.4.x. The APR libraries must be upgraded for all
  features of httpd to operate correctly.

  This release builds on and extends the Apache 2.2 API.  Modules written
  for Apache 2.2 will need to be recompiled in order to run with Apache
  2.4, and require minimal or no source code changes.

    http://svn.apache.org/repos/asf/httpd/httpd/trunk/VERSIONING

  When upgrading or installing this version of Apache, please bear in mind
  that if you intend to use Apache with one of the threaded MPMs (other
  than the Prefork MPM), you must ensure that any modules you will be
  using (and the libraries they depend on) are thread-safe.



Read More

SA-CORE-2013-002 – Drupal core – Denial of service

  • Advisory ID: DRUPAL-SA-CORE-2013-002
  • Project: Drupal core
  • Version: 7.x
  • Date: 2013-February-20
  • Security risk: Critical
  • Exploitable from: Remote
  • Vulnerability: Denial of service

Description

Drupal core’s Image module allows for the on-demand generation of image derivatives. This capability can be abused by requesting a large number of new derivatives which can fill up the server disk space, and which can cause a very high CPU load. Either of these effects may lead to the site becoming unavailable or unresponsive.

Please see the Drupal 7.20 release notes for important notes about the changes which were made to fix this issue, since some sites will require extra testing and care when deploying this Drupal core release.

CVE identifier(s) issued

  • CVE-2013-0316

Versions affected

  • Drupal core 7.x versions prior to 7.20.

Solution

Install the latest version:

Also see the Drupal core project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Drupal version: 

Read More

CVE-2013-1248 (windows_7, windows_server_2003, windows_server_2008, windows_vista, windows_xp)

Race condition in win32k.sys in the kernel-mode drivers in Microsoft Windows XP SP2 and SP3, Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2, R2, and R2 SP1, Windows 7 Gold and SP1, Windows 8, Windows Server 2012, and Windows RT allows local users to gain privileges, and consequently read the contents of arbitrary kernel memory locations, via a crafted application, a different vulnerability than other CVEs listed in MS13-016.

Read More