Microsoft Word RTF code execution

A vulnerability in Microsoft Word 2010 can allow Remote Code Execution if a user opens a malicious RTF file or previews / opens a malicious RTF email message in Microsoft Outlook while utilizing Microsoft Word as the email viewer (default for Outlook 2007, 2010 and 2013). X-Force is aware of this vulnerability being exploited in targeted attacks. A common attack vector to exploit such vulnerabilities is to send spear-phishing emails with a malicious document attached that lures the receiver to view the document thereby making them think it is from a trusted correspondent and in regards to something that is urgent or of high interest.

Read more

[Announcment] Apache HTTP Server 2.2.27 Released

                       Apache HTTP Server 2.2.27 Released

   The Apache Software Foundation and the Apache HTTP Server Project are
   pleased to announce the release of version 2.2.27 of the Apache HTTP
   Server ("Apache").  This version of Apache is principally a security
   and bug fix maintenance release.

   CVE-2014-0098 (cve.mitre.org)
     Segfaults with truncated cookie logging.
     mod_log_config: Prevent segfaults when logging truncated
     cookies. Clean up the cookie logging parser to recognize
     only the cookie=value pairs, not valueless cookies.

   CVE-2013-6438 (cve.mitre.org)
     mod_dav: Keep track of length of cdata properly when removing
     leading spaces. Eliminates a potential denial of service from
     specifically crafted DAV WRITE requests

   We consider the Apache HTTP Server 2.4 release to be the best version
   of Apache available, and encourage users of 2.2 and all prior
   versions to upgrade.  This 2.2 maintenance release is offered for
   those unable to upgrade at this time.  For further details, see:

     http://www.apache.org/dist/httpd/Announcement2.4.txt

   Apache HTTP Server 2.4 and 2.2.27 are available for download from:

     http://httpd.apache.org/download.cgi

   Please see the CHANGES_2.2 file, linked from the download page, for a
   full list of changes.  A condensed list, CHANGES_2.2.27 includes only
   those changes introduced since the prior 2.2 release.  A summary of
   all of the security vulnerabilities addressed in this and earlier
   releases is available:

     http://httpd.apache.org/security/vulnerabilities_22.html

   This release includes the Apache Portable Runtime (APR) version 1.5.0
   and APR Utility Library (APR-util) version 1.5.3, bundled with the
   tar and zip distributions.  The APR libraries libapr and libaprutil
   (and on Win32, libapriconv version 1.2.1) must all be updated to
   ensure binary compatibility and address many known security and
   platform bugs. APR version 1.5 and APR-util version 1.5 represent
   minor version upgrades from earlier httpd 2.2 source distributions.

   This release builds on and extends the Apache 2.0 API and is
   superceeded by the Apache 2.4 API.  Modules written for Apache 2.0
   or 2.4 will need to be recompiled in order to run with Apache 2.2,
   and most will require minimal or no source code changes.

   When upgrading or installing this version of Apache, please bear in
   mind that if you intend to use Apache with one of the threaded MPMs
   (other than the Prefork MPM), you must ensure that any modules you
   will be using (and the libraries they depend on) are thread-safe.


Read More

CVE-2013-6438

The dav_xml_get_cdata function in main/util.c in the mod_dav module in the Apache HTTP Server before 2.4.8 does not properly remove whitespace characters from CDATA sections, which allows remote attackers to cause a denial of service (daemon crash) via a crafted DAV WRITE request. (CVSS:5.0) (Last Update:2014-09-04)

Read More

CVE-2014-0098

The log_cookie function in mod_log_config.c in the mod_log_config module in the Apache HTTP Server before 2.4.8 allows remote attackers to cause a denial of service (segmentation fault and daemon crash) via a crafted cookie that is not properly handled during truncation. (CVSS:5.0) (Last Update:2014-09-04)

Read More

ANNOUNCE: Apache HTTP Server 2.4.9 Released

          Apache HTTP Server 2.4.9 Released

The Apache Software Foundation and the Apache HTTP Server Project
are pleased to announce the release of version 2.4.9 of the Apache
HTTP Server ("Apache").  This version of Apache is our latest GA
release of the new generation 2.4.x branch of Apache HTTPD and
represents fifteen years of innovation by the project, and is
recommended over all previous releases. This release of Apache is
principally a security, feature and bug fix release.

CVE-2014-0098 (cve.mitre.org)
 Segfaults with truncated cookie logging.
 mod_log_config: Prevent segfaults when logging truncated
 cookies. Clean up the cookie logging parser to recognize
 only the cookie=value pairs, not valueless cookies.

CVE-2013-6438 (cve.mitre.org)
 mod_dav: Keep track of length of cdata properly when removing
 leading spaces. Eliminates a potential denial of service from
 specifically crafted DAV WRITE requests

Also in this release are some exciting new features including:

*) Finer control over scoping of RewriteRules
*) Unix Domain Socket (UDS) support for mod_proxy backends.
*) Support for larger shared memory sizes for mod_socache_shmcb
*) mod_lua and mod_ssl enhancements
*) Support named groups and backreferences within the LocationMatch,
 DirectoryMatch, FilesMatch and ProxyMatch directives.

We consider this release to be the best version of Apache available, and
encourage users of all prior versions to upgrade. [NOTE: 2.4.8 was not
released.]

Apache HTTP Server 2.4.9 is available for download from:

 http://httpd.apache.org/download.cgi

Apache 2.4 offers numerous enhancements, improvements, and performance
boosts over the 2.2 codebase.  For an overview of new features
introduced since 2.4 please see:

 http://httpd.apache.org/docs/trunk/new_features_2_4.html

Please see the CHANGES_2.4 file, linked from the download page, for a
full list of changes. A condensed list, CHANGES_2.4.9 includes only
those changes introduced since the prior 2.4 release.  A summary of all 
of the security vulnerabilities addressed in this and earlier releases 
is available:

 http://httpd.apache.org/security/vulnerabilities_24.html

This release requires the Apache Portable Runtime (APR) version 1.5.x
and APR-Util version 1.5.x. The APR libraries must be upgraded for all
features of httpd to operate correctly.

This release builds on and extends the Apache 2.2 API.  Modules written
for Apache 2.2 will need to be recompiled in order to run with Apache
2.4, and require minimal or no source code changes.

 http://svn.apache.org/repos/asf/httpd/httpd/trunk/VERSIONING

When upgrading or installing this version of Apache, please bear in mind
that if you intend to use Apache with one of the threaded MPMs (other
than the Prefork MPM), you must ensure that any modules you will be
using (and the libraries they depend on) are thread-safe.



Read More