All posts by 007admin

CVE-2009-3896

src/http/ngx_http_parse.c in nginx (aka Engine X) 0.1.0 through 0.4.14, 0.5.x before 0.5.38, 0.6.x before 0.6.39, 0.7.x before 0.7.62, and 0.8.x before 0.8.14 allows remote attackers to cause a denial of service (NULL pointer dereference and worker process crash) via a long URI. (CVSS:5.0) (Last Update:2013-09-11)

Read More

CVE-2009-3898

Directory traversal vulnerability in src/http/modules/ngx_http_dav_module.c in nginx (aka Engine X) before 0.7.63, and 0.8.x before 0.8.17, allows remote authenticated users to create or overwrite arbitrary files via a .. (dot dot) in the Destination HTTP header for the WebDAV (1) COPY or (2) MOVE method. (CVSS:4.9) (Last Update:2012-06-08)

Read More

CVE-2009-3555 – apache/mod_ssl vulnerability and mitigation

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Subject: CVE-2009-3555 - apache/mod_ssl vulnerability and mitigation

Apache httpd is affected by CVE-2009-3555[1] (The SSL Injection 
or MiM attack[2]).

The Apache httpd webserver relies on OpenSSL for the implementation of 
the SSL/TLS protocol.

We strongly urge you to upgrade to OpenSSL 0.9.8l; and to be prepared 
to deploy OpenSSL 0.9.8m as it becomes available[3]. 

Note that these are for short term and mid-term mitigation only; the 
long term solution may well require a modification of the SSL and/or 
TLS protocols[4].

For those who are not able to upgrade OpenSSL swiftly and/or for 
those who need detailed logging - we recommend that you roll out 
this patch[5]:

  http://www.apache.org/dist/httpd/patches/
       apply_to_2.2.14 CVE-2009-3555-2.2.patch
 sha1: 28cd58f3758f1add39417333825b9d854f4f5f43

as soon as possible. This is a partial fix in lieu of the protocol 
issues being addressed and further changes to OpenSSL. Like the 
OpenSSL 0.9.8l stopgap measure this patch rejects 
in-session renegotiation.

If you are unable to patch and unable to roll our a newer version of 
OpenSSL, and you rely on Client Side Authentication with Certificates 
then we recommend that you 1) ensure that you limit your configuration 
to a single 'SSLClient require' on VirtualHost/Sever level and 2) 
remove all other (re)negotiation/require directives. However this does 
NOT fully protect you - it just curtails authentication in this 
specific setting.



1: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3555
2: http://www.links.org/?p=780, http://extendedsubset.com/?p=8
3: http://www.openssl.org/source/
   openssl-announce mailing list on
   http://www.openssl.org/support/community.html
4: http://www.ietf.org/mail-archive/web/tls/current/msg03963.html
5: svn diff -r833581:833594 https://svn.apache.org/repos/asf/
   httpd/httpd/trunk/modules/ssl 

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Darwin)

iQCVAwUBSvTOITGmPZbsFAuBAQKpXgQAgoBq0FjmnFwxBYjZQ05cPgHYzE+rBQHg
f142MZWXreBoZyB1pV2CJpmf7BWtmBKQgKIMwk3fWfRs33rvnjhEWjrMBFA4ID8J
0CBLmiwBVxLfCTj7YIBJ71VPn4Mw3iviiIUb1qrW0RaOjGgf4j2ffsapnlpR6lR9
JHDVPFBXl8s=
=OYuY
-----END PGP SIGNATURE-----


Read More

CVE-2009-3272

Stack consumption vulnerability in WebKit.dll in WebKit in Apple Safari 3.2.3, and possibly other versions before 4.1.2, allows remote attackers to cause a denial of service (application crash) via JavaScript code that calls eval on a long string composed of A/ sequences. (CVSS:5.0) (Last Update:2011-02-17)

Read More

SA-CORE-2009-008 – Drupal core – Multiple vulnerabilities

  • Advisory ID: DRUPAL-SA-CORE-2009-008
  • Project: Drupal core
  • Version: 5.x, 6.x
  • Date: 2009-September-16
  • Security risk: Critical
  • Exploitable from: Remote
  • Vulnerability: Multiple vulnerabilities

Description

Multiple vulnerabilities and weaknesses were discovered in Drupal.

OpenID association cross site request forgeries

The OpenID module in Drupal 6 allows users to create an account or log into a Drupal site using one or more OpenID identities.

The core OpenID module does not correctly implement Form API for the form that allows one to link user accounts with OpenID identifiers. A malicious user is therefore able to use cross site request forgeries to add attacker controlled OpenID identities to existing accounts. These OpenID identities can then be used to gain access to the affected accounts.

This issue affects Drupal 6.x only.

OpenID impersonation

The OpenID module is not a compliant implementation of the OpenID Authentication 2.0 specification. An implementation error allows a user to access the account of another user when they share the same OpenID 2.0 provider.

This issue affects Drupal 6.x only.

File upload

File uploads with certain extensions are not correctly processed by the File API. This may lead to the creation of files that are executable by Apache. The .htaccess that is saved into the files directory by Drupal should normally prevent execution. The files are only executable when the server is configured to ignore the directives in the .htaccess file.

This issue affects Drupal 6.x only.

Session fixation

Drupal doesn’t regenerate the session ID when an anonymous user follows the one time login link used to confirm email addresses and reset forgotten passwords. This enables a malicious user to fix and reuse the session id of a victim under certain circumstances.

This issue affects Drupal 5.x only.

Versions affected

  • Drupal 6.x before version 6.14.
  • Drupal 5.x before version 5.20.

Solution

Install the latest version:

  • If you are running Drupal 6.x then upgrade to Drupal 6.14.
  • If you are running Drupal 5.x then upgrade to Drupal 5.20.

If you are unable to upgrade immediately, you can apply a patch to secure your installation until you are able to do a proper upgrade. Theses patches fix the security vulnerabilities, but do not contain other fixes which were released in Drupal 6.14 or Drupal 5.20.

Important note: Some users using OpenID might not be able to use the existing OpenID associations to login after the upgrade. These users should use the one time login via password recovery to get access to their user account and re-add desired associations. These users likely had issues with OpenID logins prior to the upgrade.

Reported by

The session fixation issue was reported by Noel Sharpe.
OpenID impersonation was reported by Robert Metcalf.
OpenID association CSRF was reported by Heine Deelstra (*).
The file upload issue was reported by Heine Deelstra (*).

(*) Member of the Drupal security team

Fixed by

The session fixation issue was fixed by Jakub Suchy.
The OpenID and file upload issues were fixed by Heine Deelstra.

Contact

The security team for Drupal can be reached at security at drupal.org or via the form at http://drupal.org/contact.

Drupal version: 

Read More

Apache HTTP Server 2.2.13 Released


   The Apache Software Foundation and the Apache HTTP Server Project are
   pleased to announce the release of version 2.2.13 of the Apache HTTP
   Server ("Apache").  This version of Apache is principally a security
   and bug fix release.  Notably, this version bundles the APR Library
   version 1.3.8 and APR Utility Library version 1.3.9, which address
   a security concern which may be triggered by some third party modules.

   We consider this release to be the best version of Apache available, and
   encourage users of all prior versions to upgrade.

   Apache HTTP Server 2.2.13 is available for download from:

     http://httpd.apache.org/download.cgi

   Apache 2.2 offers numerous enhancements, improvements, and performance
   boosts over the 2.0 codebase.  For an overview of new features
   introduced since 2.0 please see:

     http://httpd.apache.org/docs/2.2/new_features_2_2.html

   Please see the CHANGES_2.2 file, linked from the download page, for a
   full list of changes.  A condensed list, CHANGES_2.2.13 provides the
   complete list of changes since 2.2.12. A summary of security
   vulnerabilities which were addressed in the previous 2.2.12 and earlier
   releases is available:

     http://httpd.apache.org/security/vulnerabilities_22.html

   Apache HTTP Server 1.3.41 and 2.0.63 legacy releases are also currently
   available.  See the appropriate CHANGES from the url above.  See the
   corresponding CHANGES files linked from the download page.  The Apache
   HTTP Project developers strongly encourage all users to migrate to
   Apache 2.2, as only limited maintenance is performed on these legacy
   versions.

   This release includes the Apache Portable Runtime (APR) version 1.3.8
   bundled with the tar and zip distributions.  The APR libraries libapr
   and libaprutil (and on Win32, libapriconv) must all be updated to ensure
   binary compatibility and address many known security and platform bugs.

   This release builds on and extends the Apache 2.0 API.  Modules written
   for Apache 2.0 will need to be recompiled in order to run with Apache
   2.2, and require minimal or no source code changes.

     http://svn.apache.org/repos/asf/httpd/httpd/branches/2.2.x/VERSIONING

   When upgrading or installing this version of Apache, please bear in mind
   that if you intend to use Apache with one of the threaded MPMs (other
   than the Prefork MPM), you must ensure that any modules you will be
   using (and the libraries they depend on) are thread-safe.



Read More