Ignite Realtime Openfire Version 3.7.1 Reflected Cross Site Scripting (CVE-2018-11688)


fulldisclosure logo
Full Disclosure
mailing list archives

Re: Ignite Realtime Openfire Version 3.7.1 Reflected Cross Site Scripting (CVE-2018-11688)


From: Simon Waters
Date: Wed, 6 Jun 2018 12:06:54 +0100


Thanks Yavuz,

this appears to have been addressed in 3.9.2 release of OpenFire in May
2014.

I'm unable to reproduce in OpenFire 4.2.3.

I would strongly suggest running the latest version of OpenFire (4.2.3 at
time of writing) as there were multiple XSS and other security issues
(missing CSRF for example) addressed since 3.7.1.

I'd also suggest people exercise caution with the OpenFire admin interface,
although we've found and resolved a number of issues through testing, there
is no CSP or other systematic control to prevent XSS in the event one of
the filters is missing or misconfigured. I'm know (personal communication)
that the developers do intend to add such controls in future releases.

The Ignite Realtime Security contact address for reporting OpenFire issues
is security () igniterealtime org

_______________________________________________
Sent through the Full Disclosure mailing list
https://nmap.org/mailman/listinfo/fulldisclosure
Web Archives & RSS: http://seclists.org/fulldisclosure/




  By Date  
     
  By Thread  

Current thread:


Read Original
Author: