—–BEGIN PGP SIGNED MESSAGE—–
This email refers to the advisory found at
Product: Fisheye and Crucible.
Affected Fisheye and Crucible product versions:
version < 4.4.3
4.5.0 <= version < 4.5.1
Fixed Fisheye and Crucible product versions:
* for 4.4.x, Fisheye 4.4.3 has been released with a fix for this issue.
* for 4.4.x, Crucible 4.4.3 has been released with a fix for this issue.
* for 4.5.x, Fisheye 4.5.1 has been released with a fix for this issue.
* for 4.5.x, Crucible 4.5.1 has been released with a fix for this issue.
This advisory discloses a critical severity security vulnerability which affects
Fisheye and Crucible.
Versions of Fisheye and Crucible before version 4.4.3 (the fixed version for
4.4.x) and from version 4.5.0 before 4.5.1 (the fixed version for 4.5.x) are
affected by this vulnerability.
Customers who have upgraded their Fisheye and Crucible installations to version
4.4.3 or 4.5.1 are not affected.
Customers who have downloaded and installed Fisheye or Crucible less than 4.4.3
(the fixed version for 4.4.x) or who have downloaded and installed
Fisheye or Crucible >= 4.5.0 but less than 4.5.1 (the fixed version for 4.5.x)
please upgrade your Fisheye and Crucible installations immediately to fix
Argument injection in Mercurial repository handling (CVE-2017-8907)
Atlassian rates the severity level of this vulnerability as critical, according
to the scale published in our Atlassian severity levels. The scale allows us to
rank the severity as critical, high, moderate or low.
This is our assessment and you should evaluate its applicability to your own IT
Fisheye and Crucible did not check that the name of a file in a Mercurial
repository contained argument parameters. An attacker who has permission to add
a repository or commit to a mercurial repository tracked by Fisheye or Crucible,
can execute code of their choice on systems that run a vulnerable version of
Fisheye or Crucible. All versions of Fisheye and Crucible before 4.4.3 (the
fixed version for 4.4.x) and from 4.5.0 before 4.5.1 (the fixed version for
4.5.x) are affected by this vulnerability.
This issue can be tracked for Fisheye at:
This issue can be tracked for Crucible at
To address this issue, we’ve released the following versions containing a fix:
* Fisheye version 4.4.3
* Crucible version 4.4.3
* Fisheye version 4.5.1
* Crucible version 4.5.1
Upgrade Fisheye and Crucible to version 4.5.1 or higher.
The vulnerabilities and fix versions are described above. If affected, you
should upgrade to the latest version immediately.
If you are running Fisheye or Crucible 4.4.x and cannot upgrade to 4.5.1,
upgrade to version 4.4.3.
For a full description of the latest version of Fisheye, see
the release notes found at
https://confluence.atlassian.com/display/FISHEYE/Fisheye+releases. You can
download the latest version of Fisheye from the download centre found at
For a full description of the latest version of Crucible, see
the release notes found at
https://confluence.atlassian.com/display/CRUCIBLE/Crucible+releases. You can
download the latest version of Crucible from the download centre found at
If you have questions or concerns regarding this advisory, please raise a
support request at https://support.atlassian.com/.
—–BEGIN PGP SIGNATURE—–
—–END PGP SIGNATURE—–